Temat: Excel Zliczanie parzystych i nieparzystych wartości

Cześć
Znalazłem rozwiązanie w sieci
SUMA.ILOCZYNÓW(–(MOD(A1:A16;2)=0);–(A1:A16;""))

Ale nie rozumiem znaczenie “–” w wyrażeniu - bez nich (...) Zobacz więcej
9.08.2013, 15:41
Bogdan

Bogdan Gilarski www.excelperfect.pl
Perfect And
Practical

Temat: Excel Zliczanie parzystych i nieparzystych wartości

Formuła jest niepoprawna, powinna wyglądać
=SUMA.ILOCZYNÓW(-(MOD(A1:A16;2)=0);-(A1:A16))
W środku masz pytanie natury logicznej, czy reszta z dzielenia liczby z A1 wynosi 0. Odpowiedźią jest zmienna typu logicznego PRAWDA lub FAŁSZ.
Potem pytanie o A2, A3 ... do A16.
Otrzymujesz tablicę wyników {PRAWDA, PRAWDA, FAŁSZ, itd...}
Minus przed MOD(..) to wykonanie działania matematycznego polegającego na przemnożeniu tablicy wyników przez -1, co spowoduje konwersję zmiennych typu logicznego na ich odpowiedniki matematyczne, czyli 1 i 0, zatem przykładowa tablica otrzyma postać
{-1,-1,0,itd} i taka tablica stanie się PIERWSZYM argumentem funkcji SUMA.ILOCZYNÓW().
Następnie tablica ta zostanie przemnożona przez tablicę z wartościami z komórek A1:A16, ale również przemnożonymi przez -1, bo w pierwszej są minusy
Reszta chyba jest już jasna?
Jak nie chcesz mnożyć przez -1, to rozpracuj inny przykład
=SUMA.ILOCZYNÓW(1*(MOD(A1:A16;2)=0);A1:A16)
Ten post został edytowany przez Autora dnia 09.08.13 o godzinie 18:22
9.08.2013, 18:20

Temat: Excel Zliczanie parzystych i nieparzystych wartości

Dziękuję ,drugi parametr ;--(A1:A16<>"" ma eliminować komórki puste
Nie wiedziałem że w funkcji SUMA.ILOCZYNÓW nie może być sumowana wartość logiczna bo przecież
PRAWDA ma wartość liczbową 1 , np. formuła =(1=1)+(1=1) nie jest błędna i ma wartość 2
Poza tym w formułach tablicowych zmienne logiczne też są prawidłowo liczone (...) Zobacz więcej
12.08.2013, 09:46
Bogdan

Bogdan Gilarski www.excelperfect.pl
Perfect And
Practical

Temat: Excel Zliczanie parzystych i nieparzystych wartości

Drugi argument, który podałeś teraz jest inny niż w pierwszym poście.

PRAWDA/FAŁSZ to zmienne logiczne, natomiast 1 i 0 to wartości matematyczne.
Problemem nie jest tutaj ani funkcja SUMA.ILOCZYNÓW() ani rodzaj formuły (zwykła vs tablicowa) ale mnożenie tablic zawierających różne typy zmiennych.
Jeżeli pierwsza tablica ma wartości
{PRAWDA, FAŁSZ} a druga {5,10} to ich przemnożenie zwróci 0.
Należy doprowadzić wartości tablic do jednego typu, na przykład wartości matematycznych.
W tym celu pierwszą tablicę należy (na przykład) przemnożyć przez 1 lub -1 dokonując w tym momencie konwersji zmiennych logicznych na ich matematyczne odpowiedniki (...) Zobacz więcej
12.08.2013, 14:17

Temat: Excel Zliczanie parzystych i nieparzystych wartości

Dzięki
Roziemiem
12.08.2013, 14:54

Następna dyskusja:

Excel 2013 - przypisanie ma...




Zobacz dyskusje w grupie Excel

Aktualne tematy

Zobacz o czym się teraz dyskutuje

Problemy i porady

Znajdź odpowiedzi na swoje pytania

Wyślij zaproszenie do